Sunday, May 16, 2010

Been busy

It's been a while since my last post, so I decided to write a little bit of my last couple of months.

Lotus Sametime 8.5
After a few tries in my test environment, I have Lotus Sametime 8.5 up and running. I've hit some pitfalls and I hope to have more posted regarding that soon. Working with Websphere is different from anything I have seen. The new Sametime Proxy web client is very cool however I still cannot get it to communicate to the Sametime Meeting server, only with the Sametime Classic server. Also I had some issues installing the Sametime System Console. At first I thought it was related to the install path ( through about 4 trial and errors it seem the install path was the only thing causing this installation error ) However, the fifth time I installed the Sametime system console it worked so I am still trying to figure out that issue.



Lotus Connections 2.5
Lotus Connections 2.5 documentation helped me get Lotus Connections up and running with a stand alone install. However, the lack of documentation or even some of the confusing 'optional' configurations will cause the entire server to stop playing nice. I have a lot of good info from my Lotus Connections 2.5 experiences, again I will try and find time to post.


Lotus Domino 6.5 end of life support
Going from Lotus Domino 6.5 to 8.5.1 FP2 has been a success. However some very strange issues have cropped up here and there. More on this to come too.


Lotus Quickplace 6.5.1 to Lotus Quickr 8.2
Did my first ever Quickplace to Quickr upgrade. I used the Quickr wiki upgrade page:

http://www-10.lotus.com/ldd/lqwiki.nsf/dx/overview-of-upgrading-from-quickplace-to-quickr-8.2

This wiki was excellent! Except for a broken link that I still cannot access ( it has been down for about two weeks now ) under 'Upgrading places and placetypes' and clicking on 'Upgrading all places and placetypes at once'

http://www-10.lotus.com/ldd/lqwiki.nsf/dx/upgrading-all-places-and-placetypes-at-once-when-completing-the-upgrade-from-quickplace-to-quickr-8.2

I get a

Unexpected runtime error

The runtime has encountered an unexpected error.

Error source

Page Name:/page.xsp

Exception

Error while executing active content filter
Exception in processing active content: Illegal state: 11 (NAME_CHAR)
Illegal state: 11 (NAME_CHAR)


com.ibm.xsp.FacesExceptionEx: Error while executing active content filter     com.ibm.xsp.acf.ACFProcessor._processMarkup(ACFProcessor.java:91)     com.ibm.xsp.acf.ACFProcessor.processMarkup(ACFProcessor.java:77)     com.ibm.xsp.util.FacesUtil.convertValue(FacesUtil.java:1043)     com.ibm.xsp.renderkit.html_basic.ReadOnlyRteRenderer.encodeText(ReadOnlyRteRenderer.java:85)     com.ibm.xsp.renderkit.html_basic.ReadOnlyRteRenderer.encodeValue(ReadOnlyRteRenderer.java:49)     com.ibm.xsp.renderkit.html_basic.ReadOnlyValueRenderer.encodeBegin(ReadOnlyValueRenderer.java:69)     com.ibm.xsp.renderkit.ReadOnlyAdapterRenderer.encodeBegin(ReadOnlyAdapterRenderer.java:116)     com.ibm.xsp.renderkit.ReadOnlyAdapterRenderer.encodeBegin(ReadOnlyAdapterRenderer.java:116)     javax.faces.component.UIComponentBase.encodeBegin(UIComponentBase.java:952)     com.ibm.xsp.util.FacesUtil.renderComponent(FacesUtil.java:743)



But I've figured out the command is just:

Force the upgrade of all places and placetypes on the server
load qptool upgrade -a -f

Other than that the upgrade went very smoothly. Had to add a quickplace after the upgrade. To do this start at 'Completing the upgrade from IBM Lotus Quickplace to Lotus Quickr':

http://www-10.lotus.com/ldd/lqwiki.nsf/dx/completing-the-upgrade-from-quickplace-to-quickr


and use the -p placename parameter like so

load qptool unlock -p placename
load qptool upgrade -f -p placename
load qptool register -p placename -install
load qptool upgrade -p placename -f
load qptool unregister -p placename –placecatalog
load qptool register -p placename –placecatalog

Also, the documentation says
load qptool unregister –a –placecatalog
and
load qptool register –a –placecatalog

but that syntax is not correct, you must put the -placecatalog first
load qptool unregister –placecatalog –a
and
load qptool register –placecatalog –a




That is all I have for now.

1 comment: