Monday, October 12, 2009

Lotus Notes 8.5.1 upgrade

Please read this first before proceeding: AllClient Errors


I had a co-worker get "Cannot upgrade AllClient installation to Notes client. The upgrade you are attempting is not supported" when upgrading from 8.5 to 8.5.1. After some google searching I found that you have to change the InstallType=2 to InstallType=6 in your notes.ini.

Update:
I've been noticing a lot of traffic to this web page so I decided to re-vist this post:
Here is a list of valid values for Installtype


Valid Values for notes 7 are:
2 - All client install (including Designer and Administrator)
3 - Notes client only
In previous versions of Notes this variable had many more values. It used to be used to Identifies the type of Notes client installed, as follows:
0 = Designer License Type
1 = Administration License Type
2 = Designer and Administration License Type
3 = Domino Mail Server License Type
4 = Domino Enterprise Server License Type
5 = Domino Application Server License Type
6 = Notes Client License Type
7 = Notes lite License Type
9 = Unknown, set by default at start of installation process, set for shared install


In this instance, a co worker was trying to install the admin / designer 8.5.1 client over the admin / designer 8.5 client. Why the InstallType needed to be changed from 2 to 6 is beyond me, but it works. IBM also has a tech note relating to this and they explain that the difference is between older versions and the 'all client' and 'client only'. Check the reference below under Upgrade. IBM's official fix for this is to uninstall Lotus Notes and install the correct package.

For smart upgrade users, this can be an issue when trying to roll out the installer. check the reference below for the full detail. The error is the same, the InstallType is 2 and needs to be changed to 6.


reference:
InstallType:
http://www-10.lotus.com/ldd/dominowiki.nsf/dx/installtype
Upgrade to Notes 8 client fails with the error: 'The upgrade you are attempting is not supported'
http://www-01.ibm.com/support/docview.wss?uid=swg21271989
Smart Upgrade:
http://www-01.ibm.com/support/docview.wss?uid=swg21330176

8 comments:

  1. I got the same error. I was trying to upgrade a client / admin / designer 8.5 install with the client only 8.5.1 files. I downloaded the 8.5.1 designer client and the upgrade worked fine.

    ReplyDelete
  2. Update on this: make sure you are installing the correct version of Lotus Notes. The new naming scheme IBM gave the install files are ... different. If you are sure you have the correct version, go ahead and change the installtype

    ReplyDelete
  3. We had the same issue for 150 users, we realized before the upgrade. I made a vbscript file that changes the install type from 2 to 6. I implemented this in our logon script to make the changes and it worked very well. I have copied the script below. Copy it to a notepad file and rename it to whatever you wish .vbs:

    Set objFSO = CreateObject("Scripting.FileSystemObject")

    If objFSO.FileExists("C:\Program Files\lotus\notes\notes.ini") Then

    Const ForReading = 1
    Const ForWriting = 2

    Set objFSO = CreateObject("Scripting.FileSystemObject")
    Set objFile = objFSO.OpenTextFile("C:\Program Files\lotus\notes\notes.ini", ForReading) ' Read the file for "InstallType =2"

    strText = objFile.ReadAll
    objFile.Close

    If InStr(strText, "InstallType=6") Then
    blnFound = True
    If blnFound Then
    End If
    WScript.quit
    else

    strNewText = Replace(strText, "InstallType=2", "InstallType=6")

    Set objFile = objFSO.OpenTextFile("C:\Program Files\lotus\notes\notes.ini", ForWriting) ' "Writes new InstallType"
    objFile.WriteLine strNewText
    objFile.Close

    MsgBox "Modification of your Lotus Notes Configuration file has been made in preparation for the upcoming Lotus Notes Upgrade. You may close this window.",64,"Preliminary Configuration for Lotus Notes Upgrade" ' Shows "Finished" message
    End If


    Else
    MsgBox "Contact Darren Skidmore via E-Mail to remedy this configuration.",16,"Preliminary Configuration for Lotus Notes Upgrade"
    End If

    wscript.quit ' Exits the script

    ReplyDelete
  4. Google brought me here. This is exactly what I was looking for, thanks!

    /Hate Notes >8(

    ReplyDelete
  5. Glad this helped but Notes is pretty good program considering everything it can do! :)

    ReplyDelete
  6. wow! i am trying to uninstall 8.5.3, and i got the error, i replaced that installtype and it worked! thanks!

    ReplyDelete
  7. Just wanted to say thanks for posting this. This fix still works for current versions. I was upgrading from 9.0 to 9.0.1 and was getting this error. Changing the InstallType from 2 to 6 worked! :)

    ReplyDelete